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W| Using Microsoft Excel
Advanced Skills

Excel contains numerous tools that are intended to meet a wide range
of requirements. Some of the more specialised tools are useful to only
certain types of people while others have value for more general excel
users. These exercises will cover some of the advanced features that may
be useful for most excel users. These features will include cell naming,
cell notes, conditional formatting, data validation and custom number
formats.

Naming Cells

In a large spreadsheet, cell referencing and selection may be simplified by making use
of names. You can assign a unique name to an individual cell or to a range of cells.
This can make it quicker and easier to refer to the cells in charts and functions.
Additionally, functions that make use of names are easier to read. For instance, a
formula that says =B4-B5 doesn’t make as much sense as a formula that says
=Sales-Expenses.

Exercise 1. Creating Cell Names
1) Create a new workbook in Excel and create a table like the one below.

| A | B
Terry's Monthly Budget

For the month of March
Diate

Income

Full tirme job
Fart time job
Toial Income

D~ 0O m =W =

Expenses
IMewy TV

Total Expenses

®:ll Savings

2) Save the file as Budget.

3) Click on Cell A3 which will have the current date.

4) Click in the names box which is to the left of the formula bar. Currently it will display the
reference of the currently selected cell.

5) Type Date in the box and press [Enter] to create the name for that cell.
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6) Click in another cell anywhere on the worksheet (or even in another worksheet).

7) Click on the dropdown arrow next to the names box. A list of names for the current
workbook will appear.

8) Click on the Date name. Excel will automatically go to, and select that
named cell, even if you were on a different sheet.

Note Whenever you select a cell or range of cells that is named, the name will appear in the names
box.

3160
9) Select the cell range B6:B7 which should contain the cells with the income amounts. IS
10) Click in the Names box, type Income and press [Enter].

Note If you type a name in the names box without pressing [Enter] afterwards, the name might not be
created.

11) Select the cell range B11:B25 which should contain the expense figures.

12) Click in the Names box, type Expenses and press [Enter].

13) Test the new named ranges by selecting them from the names dropdown list. Each TDate
range should become selected when you select its range.

14) Click in cell D8. This cell will contain the formula to calculate total income.

15) Enter the following formula.

Incorme

=Sum(Income)

Excel will make use of the range name to add up all of the cells in that range.
16) Click in cell B26 which will contain the total expenses.

17) Click on the Autosum icon. =

When the Autosum tool completes the function, it will use the range name you B :zii vonsos
have created instead of the less meaningful cell references.

SUM{number1, [number2], ...

18) Press [Enter] to complete the function.
19) Save the changes to the workbook.

B26 - A =SUM(Expenses)
A | B
Terry's Monthly Budget

For the month of March
Date

Total Expenses

Savings
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Exercise 2. Creating Names Automatically

If you have a lot of cells you want to name it is possible to have the names automatically created

for you from table headings/labels. | ame 1
1) Select A6:B8. These cells contain the income labels and amounts. L d Comment paste...
2) From the Insert menu select Name and Create. Picture | geate. |y |
2% Diagram... apply,.,
— — Ohiect... Label...

| Botkom row
| Right column

K | Caneel |

3) We want the data cells to be named based on the cells in the left column so make sure the
Left column option is selected and then click OK.

4) Click in cell B6, B7 or B8. Look in the Names box to see the names that | Total_Income =
have been created. Notice that names with more than one word have been created using an
underscore. E.g. cell B8 will now have the name Total_Income. This is because names
cannot contain spaces. Names must also begin with a letter.

5) Select the cell range B11:B25. This will contain the expenses data and labels.

6) From the Insert menu select Name and Create.

7) Click oK to define names for these cells.

We can view, modify or delete the names that have already been created by using | &= [y |
the Define Names options. Paste...

Create. ..

8) From the Insert menu select Names and then Define. A dialog box like the one Apply...
below will appear. Label...

Mames in workbook:

]Expenses | o] 1
Car_loan_repayments - ]

Date [ Close
Eating_out

Electricity bills Add
EXPENSES - — 4
Full_time_job

Gas_hils - ki -
Going_out_on_weekends

Groceries

Health_Club_Membership :1

Refers to:

|=shesti1gBs11:48425 7

This dialog lists all the names in the current workbook. From here you can delete names and
modify the cells that a name refers to.

9) Click one some of the names to view the cell references that the names refer to.
10) Click close to close the dialog without making any changes.
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Exercise 3. Pasting Names

Advanced Skills

When you are creating a formula you can use names as you have already seen. If your workbook
has a lot of names, however, then it may be difficult to type a particular name from memory.

You can’t select names from the names box since when you are editing a e

X =

formula; the names box changes in to a list of recently used functions as A

shown to the right. Instead you can insert a name in to a formula.
1) Click in cell B28. This is where we will calculate the savings in the

budget.

2) Type an equals sign = to begin a formula.

3) From the Insert menu select Name and then Paste. Notice that
many of the other menu options are not available while you are

editing a cell. A dialog box like the one below will appear.

Paste name

Other_Insurance
Part_time_job
Petral
Phone_bills

Rent
Total_Expenses

Video_rentals

[ o 1]

Cancel |

AVERAGE
- % Monthl

Eunction...

Marme 3 |

Pickure 3

4) From the list select Total _Income and click OK. The name will be inserted in to the formula.

5) Type a minus sign. —

6) From the Insert menu select Name and then Paste.
7) Select Total_Expenses from the list and click OK.

The formula should appear as =Total_Income-Total_Expenses

8) Press [Enter] to complete the formula.
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Cell Comments

Cell comments can be used to guide a user who is using your spreadsheet. They can contain tips,
and other information that may be helpful. They are indicated by a small red triangle in the top
right corner of the cell. When the mouse is moved over the cell, the note will appear for the user.
Comments can be formatted to match the look of the rest of the spreadsheet.

Exercise 4. Creating a Cell Comment

1) Select cell B20. This is the cell with the Electricity amount.

2) From the Insert menu or from the right click menu select the Comment option. A comment
will appear next to the cell with your name on it. The name is taken from the one that was
entered when Excel was installed, though this can be changed from Excel’s options.

3) Enter the text, “This bill is paid every second month” as shown below in the comment.

Steve O'Neil:
This billis paid every

second maonkh

4) Click outside the comment to finish editing it. A red mark is visible in the top right corner of
cell B20.
5) Move your mouse over the cell to view the comment.

UL -TSteve O'Neil:
M This bill is paid every

a8 second month

6) Right click on the cell and select Edit Comment.
7) Move your mouse over the border of the comment and click on the border (make sure you
are not editing the comment’s contents).

Steve O'Neil:
This bill is paid every
second month

O-lA -

8) Use the Fill Colour icon on the formatting toolbar to change the background o Fil
colour of the comment. You can also resize the comment box if you want. EEEEEEEE

9) Save the changes to the file. EEEENEEN

| | N E
Note In the page setup options, you can choose to have comments shown when you . N .

print the sheet. More F Light Green
Eill Effects...

Page | Margins | Header/Footer =~ Sheet

. 1 § 7
Prink area: I =|},; | Brint..,

Print titles

Prink Preview

Rows ko repeat at top: ] =|;g
pkions...
Columns ta repeat at left: ] B
Prink
| Gridines | Row and column headings
|_|Blackand whit= Commentsi  [(none) =
| Draft quality T = %

ool errorsaciii=) N
At end of sheet 2
| As displaved on sheet

i n [== === |
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Conditional Formatting

Conditional formatting allows you to create rules that will change the formatting in a cell based
on the values in the cell. It can be useful for highlighting certain parts of the spreadsheet when
certain conditions are met. In our table we will apply conditional formatting to highlight
different expenses.

Exercise 5. Applying Conditional Formatting

1) From the Names drop down list, select Expenses. All of the expenses cells
should be selected.

2) From the Format menu select Conditional Formatting.

3) When the dialog appears, change the options to match the example below.

AutoFormat. ..

Conditional Formatting. .. h |

Style...

[celivabve 15 ] foroater than or cqualto 3

The drop down box allows you to specify the conditions that must be met if the formatting is to
change. In this case we are telling Excel to change the formatting of cells where the value is
greater than or equal to 500.

4) Click the Format button so we can specify how the cells meeting the criteria will look. st

5) When the format options appear, set the format to Italic style and dark red colour. You can
also change the border and pattern/background of cells which match the criteria.

6) Click ok to apply the formatting and return to the conditional formatting options.

7) Click the Add button to add an additional criterion for formatting. &=

8) Change the additional criteria to Less than 70.

9) Set the formatting for the additional criteria to italic and green. The conditional formatting
options should now look like the example on the following page.
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Condtion L :
|!Ce|| Walue Is ﬂ |greater than or equal to _'r;i !S_DU

Preview of format ko use
when conditon i true: AaBbleY =

Condition 2

|CeII Yalue Is ﬂ ]Iessthan j i?D

AaBbleYylz ‘

Preview of format to use
when condition is true:

@_. bdds> | Delete.. | o | Cancel |

10) Click ok to apply the conditional formatting. Any cells with a value of 500 and above will
be italic and dark red. Cells with a value of less than 70 will be italic and green.
11) Change the numbers in some of the cells to see the changes in formatting.

12) Save the changes to your workbook.

A | B
1| Terry's Monthly Budget

For the month of March
Date

Fll Fart time jo
i} Total Income
9
{1} Expenses
1 1§

Total Expenses

vi:ll Savings
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Data Validation

If you are creating an Excel spreadsheet that will be used by other people it is

important to make it as easy to use as possible, especially if the eventual users will

be people who are not skilled at using Excel. Reducing the possibility of errors

can make a workbook easier to use and this is where Excel’s data validation @ X,

feature can be useful. Data Validation can be used in the following ways. O 278
Restrict the data that can be entered in to certain cells.

Provide a list of accepted values to assist in data entry.

Provide prompts to assist a user in data entry.

Produce meaningful error messages when incorrect data has been added.

2

Exercise 6. Viewing Existing Data

1) Open the workbook called Theatre Ticket.xls.
2) Look through the existing contents of the workbook.

A B C

: Sheipian Heatre

2

3

4

s | Ticket Number 53

6

7 Date 1210412006

g Time 19:30

g Duration 120

10 Show Title Fiddler on the Roof

11 Ticket Type 18 Adult

12 Seating 1 Main

13 .No. Seats 2 v ™
14 Ticket Total 36 Child ]
15 Concession 12
16 Pensioner 10
17

18

19 ;
a0 Balcony 0s
21 hdain 1
22 Lounge 15
3 Front Row 18

Cells A1:C23 contain the information for generating a ticket. Print Preview [& the workbook and
you will see that only these cells will print, due to the settings in Page Setup. The ranges
E27:F31 and E34:F38 won’t print but both provide information that is used in 2 lookup functions.
We can also use some of this information in our data validation. Look at Enter the duralion of e
these lookup functions in cells B11 and B12. Notice the comment in cell Bo. S
The function in B11 checks what type of ticket has been entered in C11 and then uses a Vlookup
to insert a matching ticket price. The function in B12 operates in a similar way to check the seat
type and then return an amount to multiply the ticket price by. The formula in B14 calculates the
final ticket price.

We are going to use Data Validation to both restrict and assist data entry.
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Exercise 7. Adding Data Validation Rules

1) Select cell B9. This cell contains the duration of the show in minutes. Since none of the
shows go for longer than 200 minutes, we can put in a validation rule which restricts the data
that can be entered.

2) From the Data menu select Validation. A dialog box like the one below will appear.

[ —

3) Change Allow to Whole Number. This will restrict the cell so that only whole numbers with
no decimals can be entered.

4) Change Data to less than or equal to.

5) When the Maximum box appears, enter 200 in the box to set that as the upper limit. In
addition to entering a number in this box you can also select a cell in your workbook which
has a suitable value. The options should now look like the example below.

less than or equal ko

The Input Message tab allows us to enter a popup prompt that will appear when the cell is
selected. Since the cell already has a comment, we’ll leave the Input message for this cell blank.

6) Click the Error Alert tab.

In this tab we can create a custom error message that will appear if the user enters a value not
allowed under the Validation Criteria. In this case, the error message will appear if a number
greater than 200 is entered, so we can create an error message appropriate for that situation.

The Style options determine the type of error message that will appear. For instance, a
Stop style error message will prevent the entry of invalid data while the other types are
only warnings.

ECRE)

Stop
W arning
Information

7) Make sure the Style is set to Stop.

8) In the Title enter Invalid Duration.

9) For the Error Message type, “This cell must contain a number of minutes no greater than
2007,

The options should look like the example on the following page.
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greater than 200,

10) Click ok to complete the validation rule.

11) Type a number greater than 200 in the cell and press [Enter]. Your error message will
appear.

12) Click cancel to abort the change.

Note We have only created a validation rule for a single cell. If you have several cells that are all going
to contain similar data, you can select them all so that you can create a validation rule for them
all at the same time.
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Exercise 8. Create Data Validation Lists

1) Select cell cs. This cell should contain the ticket type.
2) From the Data menu select Validation.
3) Change the Allow option to List.

The Source box will appear. This allows us to provide a list of numbers or labels that will be
accepted. Anything entered that doesn’t match something in our list will produce an error. We
can either type in each of the entries separated by a comma or select a range of cells which has
an appropriate value in each cell. Since we already have a suitable range of cells being used in
the Vlookup function, we can also use it for a data validation list.

4) Make sure your cursor is in the source box and make sure you can see the Ticket Types table
in cells E28:F31. If you can’t see it, you can click the icon 2 to the right of the source box to
temporarily hide the dialog box.

5) Select cells E28:E31. The cell references will appear in the source box. If you hid the Data
Validation Dialog in the previous step, click the icon B to display it again.

6) Make sure the In-cell dropdown option is selected. This will mean that when the cell is
selected, a dropdown list of the allowable data will appear to make data entry easier. The
options should look like the example below.

7) Change the Input Message options so that they look like the example below.

Ticket Type

Select a kicket type from the lisk. .
L4

8) Change the Error Alert options to look like the example below.

Worng 1 [cepe

A Walid tickek types are Adult, Child, Concession | =
L or Pensioner,
-

9) Click ok to complete the validation rule.
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While the cell is selected, a dropdown list will appear next to the cell along with the Input
Message. If a value is entered in the cell which doesn’t match an item in the ticket types list, a
warning message will appear.

Child
Adult

-

Concession
Pensioner

]

10) Select a ticket type from the dropdown list. Notice that all of the formulae in the worksheet
recalculate based on the changed information.

11) Select c12 — the Seating type cell.

12) Create a validation rule with the following options.

=$E$35:$E$35 3

Seating Type

Select a seating type from the list,

nformation =] [5eating Type

0 Seating tvpe should be Balcony, Main, Lounge|
v

13) Test the validation rule in cell c12 by using the list and entering invalid data.
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Custom Number Formats

Excel contains a large number of number formats to choose from. These include date, currency
and percentage formats. Each of these can be modified with different decimal places and other
options. However, there may still be cases when you would like a number style that is not
provided in the standard formats. Fortunately, it is easy to create a custom number format to suit
your needs.

Exercise 9. Creating Custom Date and Time Formats

1) Select the date in cell B7.

2) Select cells from the Format menu or use the [Ctrl] [1] shortcut.

3) Make sure the Number tab is selected.

4) Select Custom from the Category list.

5) Under Type, delete whatever is currently in there. The list below that contains several
existing custom formats and will also keep any that you create so they can be reused later.

jiprmat Cells —
Murnber  Alignment Font Border | Patterns | Protection
Cateqgory: Sample
General 38819
Mumber
Currency Type:
Accounting “
Date
Time General i
Percentage u]
Fraction 0.00
Scientific #.220
Text #,##0.00
Special #4404, H 20
#,#4#0;[Red]-#,#£40 i
Type the number farmat code, using one of the existing codes as a starting
pink.
6) Enter the following custom date code.
Type:
||:I|:| i ]

Notice that the Sample area above the Type box shows how the data in the selected cell will
look with the custom format you are creating.

Sample
12 apr 06

7) Click ok to apply the custom format. The date in the cell will now take on the new format.

Date[12 Apr 06 |

T

8) Select B8, the time cell.
9) Create the following custom time format for that cell.

Type:
|h:mm am/pm

The format should make the time in the cell look like the following example.
7:30 PM
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Exercise 10. Creating Custom Number Formats

When you create a custom number format, it is possible to create four different formats at once.
One for positive numbers, one for negative numbers, one for zero values and another for text
values. Each section in the format is separated by a semi colon.

According to Excel’s online help, if you specify only two sections, the first is used for positive
numbers and zeros, and the second is used for negative numbers. If you specify only one section,
it is used for all numbers. If you skip a section, include the ending semicolon for that section. E.g.

Format for positive numbers Format far zeros
H,H88.00 ) :[Red] (¥, #84.00):0.00;"=ales “A
Format for negative numbersl Format for text

As you saw in the date and time formats, several symbols can be used in number formats to

represent certain types of formats. Additionally, there are a couple of other guidelines to

remember.

e Any text that is to appear as part of the format needs to be enclosed in quotation marks.

e Any colours that will be included as part of the format need to be enclosed in square
brackets. [ ]

1) Select B9, the cell with the show’s duration.

2) Create the following custom format.

0 "Minutes"

The contents of the cell should now show a number (at least one digit) followed by the word
Minutes. E.g. 120 Minutes

3) Select B11, the ticket type amount cell.

4) Create the following custom currency format.

$0
5) Select cell B14, the ticket price cell and enter the following custom format.
$#,##0.00, [red]” ErrOr” ;llou

This format will result in positive numbers having a dollar sign with two decimal places. For
negative numbers, the text Error will appear in red (since the total shouldn’t result in a negative
number). If the value of the cell is zero a 0 will appear.

6) Change the number of tickets in B13 to test the format for the ticket total.
7) Save your workbook and try these custom formats on a blank worksheet and enter data in to
the cells to test the formats.

Format Suggested test data

"Remaining balance is" $###0.00 Any number

h:mm AM/PM "-" dd mmmm yyyy -now() < function to calculate current date/time
$0.00;[red]$0.00;" Zero";[green] @ + and — numbers, 0, text

$* #,##0.00 " Debit";[Red]$* (#,##0.00)" Credit" + and — numbers

"You owe" 0 "dollars" Any number

Tip Custom number formats can also be used in some other applications. For instance, they are very
useful for formatting data in Microsoft Access.

The information on the following page is taken from Excel’s online help and lists some of the
symbols that can be used in number formats.
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Displaying both text and numbers To display both text and numbers in a cell, enclose the
text characters in double quotation marks (" ") or precede a single character with a backslash (\).
Include the characters in the appropriate section of the format codes. For example, type the
format $0.00"" Surplus’;$-0.00"" Shortage™ to display a positive amount as "$125.74 Surplus"
and a negative amount as "$-125.74 Shortage." The following characters are displayed without
the use of quotation marks: $ - +/ () : ' ~ & ' (left single quotation mark) ' (right single
quotation mark) ~ { } = <> and the space character.

Including a section for text entry If included, a text section is always the last section in the
number format. Include an at sign (@) in the section where you want to display any text entered
in the cell. If the @ character is omitted from the text section, text you enter will not be
displayed. If you want to always display specific text characters with the entered text, enclose
the additional text in double quotation marks (" ") — for example, *'gross receipts for "' @

If the format does not include a text section, text you enter is not affected by the format.

Adding space To create a space the width of a character in a number format, include an
underscore () followed by the character. For example, when you follow an underscore with a
closing parenthesis (_)), positive numbers line up correctly with negative numbers that are
enclosed in parentheses.

Repeating characters To repeat the next character in the format to fill the column width,
include an asterisk (*) in the number format. For example, type 0*- to include enough dashes
after a number to fill the cell.

Decimal places and significant digits

o #displays only significant digits and does not display insignificant zeros.

e 0 (zero) displays insignificant zeros if a number has fewer digits than there are zeros in the
format.

e ?adds spaces for insignificant zeros on either side of the decimal point so that decimal
points align when formatted with a fixed-width font, such as Courier New. You can also use
? for fractions that have varying numbers of digits.

Days, months, and years Hours, minutes, and seconds
To display Use this code To display Use this code
Months as 1-12 m Hours as 0-23 H
Months as 01-12 mm Hours as 00-23 hh
Months as Jan—Dec mmm Minutes as 0-59 m
Months as January— mmmm Minutes as 00-59 mm
December Seconds as 0-59 S
Months as the first letter of | mmmmm Seconds as 00-59 SS
the month Hours as 4 AM h AM/PM
Days as 1-31 d Time as 4:36 PM h:mm AM/PM
Days as 01-31 dd Time as 4:36:03 P h:mm:ss A/P
Days as Sun-Sat ddd Elapsed time in hours; for [h]:mm
Days as Sunday—Saturday | dddd example, 25.02
Years as 00-99 yy Elapsed time in minutes; for | [mm]:ss
Years as 1900-9999 yyyy example, 63:46
Elapsed time in seconds [ss]
Fractions of a second h:mm:ss.00

Tip For more information about custom formats and examples, search the online help for, “Create or
delete a custom number format”.
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