Excel contains numerous tools that are intended to meet a wide range of requirements. Some of the more specialised tools are useful to only certain types of people while others have value for more general Excel users. These exercises will cover some of the advanced features that may be useful for most Excel users. These features will include cell naming, cell notes, conditional formatting, data validation and custom number formats.

Naming Cells

In a large spreadsheet, cell referencing and selection may be simplified by making use of names. You can assign a unique name to an individual cell or to a range of cells. This can make it quicker and easier to refer to the cells in charts and functions. Additionally, functions that make use of names are easier to read. For instance, a formula that says =B4-B5 doesn’t make as much sense as a formula that says =Sales-Expenses.

Exercise 1. Creating Cell Names

1) Create a new workbook in Excel and create a table like the one below.

```
<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Terry’s Monthly Budget</td>
</tr>
<tr>
<td>2</td>
<td>For the month of March</td>
</tr>
<tr>
<td>3</td>
<td>Date</td>
</tr>
<tr>
<td>5</td>
<td>Income</td>
</tr>
<tr>
<td>6</td>
<td>Full time job</td>
</tr>
<tr>
<td>7</td>
<td>Part time job</td>
</tr>
<tr>
<td>8</td>
<td>Total Income</td>
</tr>
<tr>
<td>10</td>
<td>Expenses</td>
</tr>
<tr>
<td>11</td>
<td>Gas</td>
</tr>
<tr>
<td>12</td>
<td>Electricity</td>
</tr>
<tr>
<td>13</td>
<td>Health Insurance</td>
</tr>
<tr>
<td>14</td>
<td>Phone bills</td>
</tr>
<tr>
<td>15</td>
<td>Food</td>
</tr>
<tr>
<td>16</td>
<td>Total Expenses</td>
</tr>
<tr>
<td>20</td>
<td>Savings</td>
</tr>
</tbody>
</table>
```

2) Save the file as Budget.
3) Click on Cell A3 which will have the current date.
4) Click in the names box which is to the left of the formula bar. Currently it will display the reference of the currently selected cell.

```
A3 Date
```
5) Type Date in the box and press [Enter] to create the name for that cell.
Using Microsoft Excel

6) Click in another cell anywhere on the worksheet (or even in another worksheet).
7) Click on the dropdown arrow next to the names box. A list of names for the current workbook will appear.
8) Click on the **Date** name. Excel will automatically go to, and select that named cell, even if you were on a different sheet.

**Note** Whenever you select a cell or range of cells that is named, the name will appear in the names box.

9) Select the cell range **B6:B7** which should contain the cells with the income amounts.
10) Click in the Names box, type **Income** and press [Enter].

**Note** If you type a name in the names box without pressing [Enter] afterwards, the name might not be created.

11) Select the cell range **B11:B25** which should contain the expense figures.
12) Click in the Names box, type **Expenses** and press [Enter].
13) Test the new named ranges by selecting them from the names dropdown list. Each range should become selected when you select its range.
14) Click in cell **D8**. This cell will contain the formula to calculate total income.
15) Enter the following formula.

\[=\text{Sum(Income)}\]

Excel will make use of the range name to add up all of the cells in that range.

16) Click in cell **B26** which will contain the total expenses.
17) Click on the **Autosum** icon. \[Σ\]

When the Autosum tool completes the function, it will use the range name you have created instead of the less meaningful cell references.

18) Press [Enter] to complete the function.
19) Save the changes to the workbook.

© Steve O’Neil 2005
Exercise 2. Creating Names Automatically

If you have a lot of cells you want to name it is possible to have the names automatically created for you from table headings/labels.

1) Select A6:B8. These cells contain the income labels and amounts.
2) From the Insert menu select Name and Create.

3) We want the data cells to be named based on the cells in the left column so make sure the Left column option is selected and then click OK.
4) Click in cell B6, B7 or B8. Look in the Names box to see the names that have been created. Notice that names with more than one word have been created using an underscore. E.g. cell B8 will now have the name Total_Income. This is because names cannot contain spaces. Names must also begin with a letter.
5) Select the cell range B11:B25. This will contain the expenses data and labels.
6) From the Insert menu select Name and Create.
7) Click OK to define names for these cells.

We can view, modify or delete the names that have already been created by using the Define Names options.

8) From the Insert menu select Names and then Define. A dialog box like the one below will appear.

This dialog lists all the names in the current workbook. From here you can delete names and modify the cells that a name refers to.

9) Click one some of the names to view the cell references that the names refer to.
10) Click Close to close the dialog without making any changes.
Exercise 3. Pasting Names

When you are creating a formula you can use names as you have already seen. If your workbook has a lot of names, however, then it may be difficult to type a particular name from memory. You can’t select names from the names box since when you are editing a formula; the names box changes in to a list of recently used functions as shown to the right. Instead you can insert a name in to a formula.

1) Click in cell B28. This is where we will calculate the savings in the budget.
2) Type an equals sign = to begin a formula.
3) From the Insert menu select Name and then Paste. Notice that many of the other menu options are not available while you are editing a cell. A dialog box like the one below will appear.

4) From the list select Total_Income and click OK. The name will be inserted in to the formula.
5) Type a minus sign –
6) From the Insert menu select Name and then Paste.
7) Select Total_Expenses from the list and click OK.

The formula should appear as =Total_Income-Total_Expenses

8) Press [Enter] to complete the formula.
Cell Comments
Cell comments can be used to guide a user who is using your spreadsheet. They can contain tips, and other information that may be helpful. They are indicated by a small red triangle in the top right corner of the cell. When the mouse is moved over the cell, the note will appear for the user. Comments can be formatted to match the look of the rest of the spreadsheet.

Exercise 4. Creating a Cell Comment
1) Select cell B20. This is the cell with the Electricity amount.
2) From the Insert menu or from the right click menu select the Comment option. A comment will appear next to the cell with your name on it. The name is taken from the one that was entered when Excel was installed, though this can be changed from Excel’s options.
3) Enter the text, “This bill is paid every second month” as shown below in the comment.

4) Click outside the comment to finish editing it. A red mark is visible in the top right corner of cell B20.
5) Move your mouse over the cell to view the comment.

6) Right click on the cell and select Edit Comment.
7) Move your mouse over the border of the comment and click on the border (make sure you are not editing the comment’s contents).

8) Use the Fill Colour icon on the formatting toolbar to change the background colour of the comment. You can also resize the comment box if you want.
9) Save the changes to the file.

Note In the page setup options, you can choose to have comments shown when you print the sheet.
Conditional Formatting

Conditional formatting allows you to create rules that will change the formatting in a cell based on the values in the cell. It can be useful for highlighting certain parts of the spreadsheet when certain conditions are met. In our table we will apply conditional formatting to highlight different expenses.

Exercise 5. Applying Conditional Formatting

1) From the Names drop down list, select Expenses. All of the expenses cells should be selected.
2) From the Format menu select Conditional Formatting.
3) When the dialog appears, change the options to match the example below.

The drop down box allows you to specify the conditions that must be met if the formatting is to change. In this case we are telling Excel to change the formatting of cells where the value is greater than or equal to 500.

4) Click the Format button so we can specify how the cells meeting the criteria will look.
5) When the format options appear, set the format to Italic style and dark red colour. You can also change the border and pattern/background of cells which match the criteria.

6) Click OK to apply the formatting and return to the conditional formatting options.
7) Click the Add button to add an additional criterion for formatting.
8) Change the additional criteria to Less than 70.
9) Set the formatting for the additional criteria to italic and green. The conditional formatting options should now look like the example on the following page.
10) Click **OK** to apply the conditional formatting. Any cells with a value of 500 and above will be *italic* and *dark red*. Cells with a value of less than 70 will be *italic* and *green*.

11) Change the numbers in some of the cells to see the changes in formatting.

12) Save the changes to your workbook.
Data Validation

If you are creating an Excel spreadsheet that will be used by other people it is important to make it as easy to use as possible, especially if the eventual users will be people who are not skilled at using Excel. Reducing the possibility of errors can make a workbook easier to use and this is where Excel’s data validation feature can be useful. Data Validation can be used in the following ways.

- Restrict the data that can be entered into certain cells.
- Provide a list of accepted values to assist in data entry.
- Provide prompts to assist a user in data entry.
- Produce meaningful error messages when incorrect data has been added.

Exercise 6. Viewing Existing Data

1) Open the workbook called Theatre Ticket.xls.
2) Look through the existing contents of the workbook.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Theopian Theatre</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Ticket Number</td>
<td>53</td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Date</td>
<td>12/04/2006</td>
</tr>
<tr>
<td>8</td>
<td>Time</td>
<td>19:30</td>
</tr>
<tr>
<td>9</td>
<td>Duration</td>
<td>120</td>
</tr>
<tr>
<td>10</td>
<td>Show Title</td>
<td>Fiddler on the Roof</td>
</tr>
<tr>
<td>11</td>
<td>Ticket Type</td>
<td>18 Adult</td>
</tr>
<tr>
<td>12</td>
<td>Seating</td>
<td>1 Main</td>
</tr>
<tr>
<td>13</td>
<td>No. Seats</td>
<td>2</td>
</tr>
<tr>
<td>14</td>
<td>Ticket Total</td>
<td>36</td>
</tr>
<tr>
<td>15</td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Cells A1:C23 contain the information for generating a ticket. Print Preview the workbook and you will see that only these cells will print, due to the settings in Page Setup. The ranges E27:F31 and E34:F38 won’t print but both provide information that is used in 2 lookup functions. We can also use some of this information in our data validation. Look at these lookup functions in cells B11 and B12. Notice the comment in cell B9.

The function in B11 checks what type of ticket has been entered in C11 and then uses a Vlookup to insert a matching ticket price. The function in B12 operates in a similar way to check the seat type and then return an amount to multiply the ticket price by. The formula in B14 calculates the final ticket price.

We are going to use Data Validation to both restrict and assist data entry.
Exercise 7. Adding Data Validation Rules

1) Select cell B9. This cell contains the duration of the show in minutes. Since none of the shows go for longer than 200 minutes, we can put in a validation rule which restricts the data that can be entered.

2) From the Data menu select Validation. A dialog box like the one below will appear.

3) Change Allow to Whole Number. This will restrict the cell so that only whole numbers with no decimals can be entered.

4) Change Data to less than or equal to.

5) When the Maximum box appears, enter 200 in the box to set that as the upper limit. In addition to entering a number in this box you can also select a cell in your workbook which has a suitable value. The options should now look like the example below.

The Input Message tab allows us to enter a popup prompt that will appear when the cell is selected. Since the cell already has a comment, we’ll leave the Input message for this cell blank.

6) Click the Error Alert tab.

In this tab we can create a custom error message that will appear if the user enters a value not allowed under the Validation Criteria. In this case, the error message will appear if a number greater than 200 is entered, so we can create an error message appropriate for that situation.

The Style options determine the type of error message that will appear. For instance, a Stop style error message will prevent the entry of invalid data while the other types are only warnings.

7) Make sure the Style is set to Stop.

8) In the Title enter Invalid Duration.

9) For the Error Message type, “This cell must contain a number of minutes no greater than 200”.

The options should look like the example on the following page.
10) Click **OK** to complete the validation rule.

11) Type a number greater than 200 in the cell and press **[Enter]**. Your error message will appear.

12) Click **Cancel** to abort the change.

**Note**  We have only created a validation rule for a single cell. If you have several cells that are all going to contain similar data, you can select them all so that you can create a validation rule for them all at the same time.
Exercise 8. Create Data Validation Lists

1) Select cell C8. This cell should contain the ticket type.
2) From the Data menu select Validation.
3) Change the Allow option to List.

The Source box will appear. This allows us to provide a list of numbers or labels that will be accepted. Anything entered that doesn’t match something in our list will produce an error. We can either type in each of the entries separated by a comma or select a range of cells which has an appropriate value in each cell. Since we already have a suitable range of cells being used in the Vlookup function, we can also use it for a data validation list.

4) Make sure your cursor is in the source box and make sure you can see the Ticket Types table in cells E28:F31. If you can’t see it, you can click the icon to the right of the source box to temporarily hide the dialog box.

5) Select cells E28:E31. The cell references will appear in the source box. If you hid the Data Validation Dialog in the previous step, click the icon to display it again.

6) Make sure the In-cell dropdown option is selected. This will mean that when the cell is selected, a dropdown list of the allowable data will appear to make data entry easier. The options should look like the example below.

![Data Validation Dialog Box](image)

7) Change the Input Message options so that they look like the example below.

![Input Message Options](image)

8) Change the Error Alert options to look like the example below.

![Error Alert Options](image)

9) Click OK to complete the validation rule.
Using Microsoft Excel
Advanced Skills

While the cell is selected, a dropdown list will appear next to the cell along with the Input Message. If a value is entered in the cell which doesn’t match an item in the ticket types list, a warning message will appear.

10) Select a ticket type from the dropdown list. Notice that all of the formulae in the worksheet recalculate based on the changed information.
11) Select C12 – the Seating type cell.
12) Create a validation rule with the following options.

13) Test the validation rule in cell C12 by using the list and entering invalid data.
Custom Number Formats

Excel contains a large number of number formats to choose from. These include date, currency and percentage formats. Each of these can be modified with different decimal places and other options. However, there may still be cases when you would like a number style that is not provided in the standard formats. Fortunately, it is easy to create a custom number format to suit your needs.

Exercise 9. Creating Custom Date and Time Formats

1) Select the date in cell B7.
2) Select Cells from the Format menu or use the [Ctrl] [1] shortcut.
3) Make sure the Number tab is selected.
4) Select Custom from the Category list.
5) Under Type, delete whatever is currently in there. The list below that contains several existing custom formats and will also keep any that you create so they can be reused later.

6) Enter the following custom date code.

```
Type:
   dd mmm yyyy
```

Notice that the Sample area above the Type box shows how the data in the selected cell will look with the custom format you are creating.

7) Click OK to apply the custom format. The date in the cell will now take on the new format.

8) Select B8, the time cell.
9) Create the following custom time format for that cell.

```
Type:
   h:mm am/pm
```

The format should make the time in the cell look like the following example.

7:30 PM
Exercise 10. Creating Custom Number Formats

When you create a custom number format, it is possible to create four different formats at once. One for positive numbers, one for negative numbers, one for zero values and another for text values. Each section in the format is separated by a semi colon.

According to Excel’s online help, if you specify only two sections, the first is used for positive numbers and zeros, and the second is used for negative numbers. If you specify only one section, it is used for all numbers. If you skip a section, include the ending semicolon for that section. E.g.

```
<table>
<thead>
<tr>
<th>Format for positive numbers</th>
<th>Format for zeros</th>
</tr>
</thead>
<tbody>
<tr>
<td>#,###.00_ ; <a href="#,###.00">Red</a>;@0.00;“Sales”</td>
<td></td>
</tr>
<tr>
<td>Format for negative numbers</td>
<td></td>
</tr>
<tr>
<td>Format for text</td>
<td></td>
</tr>
</tbody>
</table>
```

As you saw in the date and time formats, several symbols can be used in number formats to represent certain types of formats. Additionally, there are a couple of other guidelines to remember.

- Any text that is to appear as part of the format needs to be enclosed in quotation marks.
- Any colours that will be included as part of the format need to be enclosed in square brackets. [ ]

1) Select B9, the cell with the show’s duration.
2) Create the following custom format.

   0 "Minutes"

   The contents of the cell should now show a number (at least one digit) followed by the word Minutes. E.g. **120 Minutes**

3) Select B11, the ticket type amount cell.
4) Create the following custom currency format.

   $0

5) Select cell B14, the ticket price cell and enter the following custom format.

   $#,##0.00;[red]"Error";"0"

   This format will result in positive numbers having a dollar sign with two decimal places. For negative numbers, the text Error will appear in red (since the total shouldn’t result in a negative number). If the value of the cell is zero a 0 will appear.

6) Change the number of tickets in B13 to test the format for the ticket total.
7) Save your workbook and try these custom formats on a blank worksheet and enter data in to the cells to test the formats.

<table>
<thead>
<tr>
<th>Format</th>
<th>Suggested test data</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Remaining balance is&quot; $#,##0.00</td>
<td>Any number</td>
</tr>
<tr>
<td>h:mm AM/PM &quot;-&quot; dd mmmm yyyy</td>
<td>-now() ← function to calculate current date/time</td>
</tr>
<tr>
<td>$0.00;[red]$0.00;&quot;Zero&quot;;[green]$0</td>
<td>+ and – numbers, 0, text</td>
</tr>
<tr>
<td>$* #,.##0.00 &quot;Debit&quot;;[Red]$* (#,.##0.00)&quot;Credit&quot;</td>
<td>+ and – numbers</td>
</tr>
<tr>
<td>&quot;You owe&quot; 0 &quot;dollars&quot;</td>
<td>Any number</td>
</tr>
</tbody>
</table>

Tip Custom number formats can also be used in some other applications. For instance, they are very useful for formatting data in Microsoft Access.

The information on the following page is taken from Excel’s online help and lists some of the symbols that can be used in number formats.
Displaying both text and numbers  To display both text and numbers in a cell, enclose the text characters in double quotation marks (" " ) or precede a single character with a backslash (\). Include the characters in the appropriate section of the format codes. For example, type the format **\$0.00" Surplus";\$-0.00" Shortage"** to display a positive amount as "$125.74 Surplus" and a negative amount as "$-125.74 Shortage." The following characters are displayed without the use of quotation marks: \$ - + / ( ) : ! & ' (left single quotation mark) ' (right single quotation mark) ~ { } = < > and the space character.

Including a section for text entry  If included, a text section is always the last section in the number format. Include an at sign (@) in the section where you want to display any text entered in the cell. If the @ character is omitted from the text section, text you enter will not be displayed. If you want to always display specific text characters with the entered text, enclose the additional text in double quotation marks (" ") — for example, \"gross receipts for \"@.

If the format does not include a text section, text you enter is not affected by the format.

Adding space  To create a space the width of a character in a number format, include an underscore (_) followed by the character. For example, when you follow an underscore with a closing parenthesis (_)), positive numbers line up correctly with negative numbers that are enclosed in parentheses.

Repeating characters  To repeat the next character in the format to fill the column width, include an asterisk (*) in the number format. For example, type 0*- to include enough dashes after a number to fill the cell.

Decimal places and significant digits

- # displays only significant digits and does not display insignificant zeros.
- 0 (zero) displays insignificant zeros if a number has fewer digits than there are zeros in the format.
- ? adds spaces for insignificant zeros on either side of the decimal point so that decimal points align when formatted with a fixed-width font, such as Courier New. You can also use ? for fractions that have varying numbers of digits.

<table>
<thead>
<tr>
<th>Days, months, and years</th>
<th>To display</th>
<th>Use this code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Months as 1–12</td>
<td>m</td>
<td></td>
</tr>
<tr>
<td>Months as 01–12</td>
<td>mm</td>
<td></td>
</tr>
<tr>
<td>Months as Jan–Dec</td>
<td>mmm</td>
<td></td>
</tr>
<tr>
<td>Months as January–December</td>
<td>mmmmm</td>
<td></td>
</tr>
<tr>
<td>Months as the first letter of the month</td>
<td>mmmmm</td>
<td></td>
</tr>
<tr>
<td>Days as 1–31</td>
<td>d</td>
<td></td>
</tr>
<tr>
<td>Days as 01–31</td>
<td>dd</td>
<td></td>
</tr>
<tr>
<td>Days as Sun–Sat</td>
<td>ddd</td>
<td></td>
</tr>
<tr>
<td>Days as Sunday–Saturday</td>
<td>dddd</td>
<td></td>
</tr>
<tr>
<td>Years as 00–99</td>
<td>yy</td>
<td></td>
</tr>
<tr>
<td>Years as 1900–9999</td>
<td>yyyy</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Hours, minutes, and seconds</th>
<th>To display</th>
<th>Use this code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hours as 0–23</td>
<td>H</td>
<td></td>
</tr>
<tr>
<td>Hours as 00–23</td>
<td>hh</td>
<td></td>
</tr>
<tr>
<td>Minutes as 0–59</td>
<td>m</td>
<td></td>
</tr>
<tr>
<td>Minutes as 00–59</td>
<td>mm</td>
<td></td>
</tr>
<tr>
<td>Seconds as 0–59</td>
<td>s</td>
<td></td>
</tr>
<tr>
<td>Seconds as 00–59</td>
<td>ss</td>
<td></td>
</tr>
<tr>
<td>Hours as 4 AM</td>
<td>h AM/PM</td>
<td></td>
</tr>
<tr>
<td>Time as 4:36 PM</td>
<td>h:mm AM/PM</td>
<td></td>
</tr>
<tr>
<td>Time as 4:36:03 P</td>
<td>h:mm:ss A/P</td>
<td></td>
</tr>
<tr>
<td>Elapsed time in hours; for example, 25.02</td>
<td>[h]:mm</td>
<td></td>
</tr>
<tr>
<td>Elapsed time in minutes; for example, 63:46</td>
<td>[mm]:ss</td>
<td></td>
</tr>
<tr>
<td>Elapsed time in seconds</td>
<td>[ss]</td>
<td></td>
</tr>
<tr>
<td>Fractions of a second</td>
<td>h:mm:ss.00</td>
<td></td>
</tr>
</tbody>
</table>

**Tip** For more information about custom formats and examples, search the online help for, "Create or delete a custom number format".