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Using Dreamweaver 

4 – Creating a Template 
Now that the main page of our website is complete, we need to create the rest of the pages. Each 

of them will have a layout that follows the plan shown below. 

 

 

Page Heading 

Home Page content in this area 
About Us 
Gallery 
Ordering 
Contact Us 
Links 
 

 

When are creating several pages that will all be similar, we can use a template to create the basic 

structure and then use that template as a starting point as we create each individual page. While 

we create the template, we’ll be using a few new techniques. Mainly, we will use a table to 

create the layout for the page. The table will be used to position the heading and the navigation 

links on the side. Tables are a common tool for page layout in website, though later we will 

learn how styles can be an even better tool for page layout with newer browsers that correctly 

support styles. 

 

Tip Sometimes the templates in Dreamweaver might not work properly if there have been problems 
installing the program. An alternative to creating a template is to create one page with the right 
layout, then use save as to make copies of the page under different filenames and modify the 
content of each one. 

Logo 
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Exercise 1 –  Starting the Template 

In these exercises we will be continuing the Francie’s Flowerpot website created in the last 

exercises. 

1) From the File menu select New ([Ctrl] [N]). 

 

2) From the list of options, make sure Basic Page is selected in the left. Select HTML template 

and then click Create. 

A new page will be created. We will use this page as the basis for our template. The first thing 

we will do is save the template. 

3) From the File menu select Save or press [Ctrl] [S]. 

 

4) A message may appear telling us we don’t have any editable regions yet. That’s fine since 

we’ll be doing that later. If you like, you can click the Don’t warn me again option before 

clicking OK. 
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5) In the Save as area, enter Main Pages and click Save. 

Note The template will be saved in a sub folder under the folder your site is in, so you can easily open 
the template for later modifications. 

Exercise 2 –  Setting up the Navigation Table 

To create the navigation structure we are going to use nested tables. The plan shown earlier 

could be done using one table with merged cells but that has the potential to get a little messy. 

While nested tables can get complex, it is often a good solution for getting the page layout you 

want. One table with two cells a single row will be used to divide the page in to a navigation 

area on the left, with the rest of the page being used for the main heading and page content. The 

navigation cell will contain another table inside of it that will arrange the navigation links. 

1) From the Insert menu select Table. You could also press [Ctrl] [Alt] [T] or click the icon  on 

the common toolbar. 

 

2) Set the options as shown above and click OK. The options are explained below. 

For our main table we only want one row divided in to two cells. The Table width should be set 

to 100% (not 100 pixels) so that it takes up the whole page width. Border thickness of 0 will 

remove any visible border from around the cells in the table. Cell padding of 0 will mean that 

there will be no blank space around the inside edges of the cells. Cell spacing of 0 will mean that 

there will be no blank space between the cells. 

Next we will set the dimensions for the cells in the table. 
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Move your mouse to the edge of the left cell until it’s border is surrounded by a red line. When 

your mouse is in that position, you can click to select the cell. 

 

3) The properties panel will show some options relating to the selected cell(s). The left cell will 

contain the page navigation, which we want to be exactly 150 pixels wide. Enter 150 in to 

the Width option as shown below. 

 

Since we haven’t entered a width for the other cell, it will take up the remaining width of the 

table so we don’t need to change anything there. That is where we want the main page content to 

go. 

4) Select both cells. This can be easily done by clicking to the left of the table as shown. 

 

5) In the Properties panel, set the vertical alignment to top. HTML 

defaults to Middle cell alignment which means that things will sit 

halfway down. In this case and in most other cases, we’ll want the 

content of both cells to be at the top. 

6) Click inside the first cell. 

7) In the properties panel, enter #a2d39c for the background colour.  

The table should currently look like the following example. 

 

8) Select the Insert table option again (making sure you are still in the first cell).  

9) Keep the options the same as before, only this time the table will have 7 rows and 1 column 

and will be 150 pixels in width. 

10) Click in the first cell. Insert the picture called nav_logo.gif. 

Tip If your files panel is showing on the right of the screen, an easy 
way to add the image file is to drag it from the file list to the cell 
where you want it to go. 

11) With the newly inserted image selected, add Francie’s Pots as the Alt text in the Properties 

Panel.  

12) In the next cells, add the following images in the order listed. The Alt text for each is shown 

after the filename. 

a) nav_home.gif  Home 

b) nav_about.gif  About Us 

c) nav_gallery.gif Gallery 

d) nav_ordering.gif Ordering 

e) nav_contact.gif Contact Us 

f) nav_links.gif  Links 

Note The navigation bar on this website is probably a bit bigger than it should be. On some screens, 
people will have to scroll down to see the bottom links. In these exercises, however, the images 
are all a bit on the large site to make it all easier to work with. 
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The page should currently look similar to the following example. 

 

In the main section (the right cell) we would like a bar across the top that will contain the page 

heading so we’ll use another nested table to divide the cell in to a top section for the heading and 

a bottom section for the page content. 

13) Make sure you are in the right cell and insert a new table with 2 rows and 1 column as 

shown below. It needs to have 100% for the width to ensure that it fills all of the available 

space. Set the Cell padding to 2 pixels. 

 

14) In the top cell, set the background colour to #a2d39c and set the height property to 60 

(pixels). 
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Exercise 3 –  Editable Areas 

One of the most useful things about creating pages based on a template is that you can specify 

which parts of the page can be edited. This is done by inserting editable areas. Anything outside 

these areas won’t be able to be modified without changing the template itself. If you do go back 

later and change the template, pages based on that template will also be changed in all but the 

editable areas. The only areas of this page layout that we want to change on each page will be 

the heading at the top of the page and the section where the page content will be. For both of 

these places, we’ll insert an editable area. 

1) Click in the top section in the main page area. 

 

2) From the Insert menu, select Template Objects and then Editable Region. [Ctrl] [Alt] [V] 

 

3) You will be prompted for a name for the region. Enter Heading and click OK. 

4) Click in the bottom cell. 

 

5) Press [Enter] twice to create two new lines. 

6) On the last of the new lines, put a text navigation bar like the one on the index.html page 

(you can copy and paste it from there to save a little effort). The only thing that will be 

changed is the addition of a link to home (index.html). It should look like the one shown 

below. 

7) In the first line, insert another editable region called Main. The page should look similar to 

the following example. 

 

8) Save the changes to the template. 
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Exercise 4 –  Using the Template 

We have already created blank documents for the other pages to test our links, but we won’t 

keep those ones. Instead, we’ll create new pages using the template and then save the new pages 

over the top of the old ones. 

1) From the File menu select New. [Ctrl] [N] 

2) When the new file dialog appears, select the Templates tab. 

 

3) A list of your current sites will appear in the left. Francie’s Flowerpots should be selected. 

The middle section will show a list of the templates in the selected site with a preview area 

on the right. Make sure the Main Pages template is selected and click Create. 

 

4) Move your mouse outside the editable areas and a cross will appear on your mouse. 

 

5) Click in the editable area for the heading. Delete the text that is there and type About Us. 

Format it as a level 1 heading. 

6) Click in the Main editable area. Replace that text with the following. 

Francie's Flowerpots is a business located in Western Australia. All of our pots are handmade 

using quality materials and techniques. We deliver to anywhere in the world. A sample of our 

range of pots can be viewed from the Gallery page. Other types of pots or custom made pots are 

available on request. Visit our Contact page to request a complete catalogue or more 

information about what's in the gallery. 

Francie began making her own pots in the early 90s and began selling them to interested friends 

as a hobby. Since then the business has grown and we now have a team of skilled potters 

working to please our customers. We're certain that we have just the right pot for you. 
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7)  Change the Title of the page to About Us. 

 

8) Save the page as about.html. When you are prompted to replace the existing file, click Yes. 

 

9) Click at the beginning of the first line (before the text Francie's Flowerpots is a business) 

and insert the image about_francie.gif. 

10) Make sure the picture is selected. In the Properties panel, set the image Align property to 

right. This places the image at the right of the page with the text wrapping around it (Left 

alignment also causes text to wrap around an image). 

 

11) Save and preview the document. 

  

 

Note in the top right corner of the editing window, you might see a small tip 
indicating that this page is based on a template. 
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Exercise 5 –  Updating the Template 

Currently, our template has a navigation bar with no hyperlinks. We’ll return to editing our 

template and then save the changes, updating the about.html page in the process before using the 

template to create the remaining pages. 

1) Close the about.html file by clicking on the close button in the top 

right corner of the editing window or by pressing [Ctrl] [W]. 

2) On the start-up screen, you should see the template listed in the recent 

documents. You can click to reopen the template for editing. If you 

have opened a lot of files since you last edited the template it may 

not be in the list so you’ll have to open it the normal way. 

Remember that the template will normally be saved in a subfolder 

of your site called Templates so it should be easy to find. 

 

3) Click on the Home graphic in the navigation bar. 

4) Remembering what you have learned in previous exercises, create a 

hyperlink to index.html. Don’t forget that the Point to File icon  

provides a quick way of creating links. You might need to change the 

Border property of the image to 0 if a blue link border gets placed around the image. 

5) For each of the other navigation graphics, create a link to the appropriate HTML document. 

6) Save the changes to the document [Ctrl] [S]. 

You will be reminded that a document has been created based on this template that you are 

saving changes to. 

 

7) Click Update so that the about.html document gets updated with the changes. 

8) Another window may appear summarising the changes. You can close this window. 
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9) Open about.html in your web browser (or open it in Dreamweaver and preview the page). 

You will be able to see the links that are now active in the navigation bar. 

 

Shortcuts Learned 

[Ctrl] [Alt] [T]  Insert a table 
[Ctrl] [Alt] [V] Insert an editable region in to a template 
[Ctrl] [W] or [Ctrl] [F4] Close the current document 
[Ctrl] [Q] or [Alt] [F4] Exit Dreamweaver 

 


