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Adobe Drewamweaver 2021 

5 – More Page Editing 
 

By now, you should have a functional template, with one simple page based on that template. For 

the remaining pages, we’ll create each page based on the template and then save each one, 

replacing the blank ones that are already there. On each page, we will look at different elements 

that may be used in a page. 

Bulleted and Numbered Lists 
In HTML there are three types of lists. One of them, definition lists will be covered later. The ones 

we will cover now are numbered lists – referred to in HTML as Ordered Lists, and bulleted lists which 

are referred to as Unordered Lists. Each line within either type of list is referred to as a List Item. 

The example below shows both types of lists, along with the HTML that would be used to generate 

the list. 

 

 
 

Creating these lists in Dreamweaver is a lot like creating similar lists in a word processor. Like most 

elements in HTML, CSS can be used to style the lists, including changing the symbols used for the 

numbers or bullet points. 
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Exercise 1. Creating a List 

1. Select New from the File menu [Ctrl] [N]. 

2. Select the Site Templates option on the left. 

3. Select the Main Pages template from the Fancie’s Fabulous Flowerpots site. 

 

4. Make sure the  option is ticked. 

5. Click Create. 

6. Save the new document as contact.html [Ctrl] [S]. 

7. When prompted, choose Yes to replace the existing document with that name. 

 

8. Change the Page Heading text to Contact Us and change the Document Title to Francie's Flower 

Pots Website - Contact Us. 
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9. In the Main page content area, replace the placeholder text with the following. On each line 

format the first word as strong (bold) as shown by clicking the  icon in Properties or using the 

[Ctrl] [B] keyboard shortcut. 

If you would like to drop in to Francie’s Flowerpots’ store or get in touch with us 

for custom orders or other information, our details are listed below. 

Phone: 9123 9876 

Fax: 9123 6789 

Email: info@franciesflowerpots.com.au 

Address: 2/37 Petal Place, Dianella, Western Australia, 6059 

10. Select the email address in the text you have typed. 

 

11. In the Link property of the properties panel, type the email address (or copy and paste it if you 

prefer). Before the email address, type mailto: (including the colon). 

 

Note If you want a hyperlink to link to an email address, it must include the mailto: part. This will 

mean that if a user clicks on it, the web browser will tell their email program to create a new 

email addressed to the email address in the link. 

12. At the beginning of the first line (If you would like…) insert the image named icon_contact.png. 1 

13. Change the Align property of the image so that it is right aligned on the page (remember you can 

right-click the image after you have placed it and then Right from the Align menu). The page 

should look like the example below. 

 

 
1 Image credit - 7883256 © Shuo Wang | Dreamstime.com 
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14. Select the four lines that begin with the bold text. We want to create a bulleted (unordered) list 

but we’ll start by trying a numbered (ordered) list. 

15. In the Properties panel, click on the Ordered List icon.  

16. With the list still selected, right-click and select List and then Properties. 

 

 

The top options are for changing the entire list while the bottom options are for changing selected 

list items. The style options let you choose from between HTML’s five ordered list styles which 

include numbered, alphabetical and roman numeral lists. The Start count lets you choose what 

number the list will start with (1 if you don’t specify otherwise). 

17) Choose a list style and click OK. 

18) With the list still selected, click the Unordered List icon . 

 

17. Right-click the list, choose List and Properties. 

18. Choose one of the other bullet styles. 

19. Save the changes to the file and preview the page. 
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Definition Lists 
The third type of list in HTML is the Definition List. A definition list contains two types of block 

elements. There are Definition Terms and Definition Data, much like an entry in a dictionary might 

consist of a defined term followed by a detailed definition for the term. In HTML, Definition Term 

elements normally look much like normal paragraphs with the Definition Data paragraphs being 

slightly indented. A list of links is a common use for this, so we’ll create one on the Links page. 

An example of a definition list appears below, along with the source HTML. Notice that strong 

(bold) formatting has been added to each of the definition terms. 

 

 
 

Exercise 2. Creating a Definition List 

1. Create a new page based on the same template we used in the last exercise. 

2. Save the new page as links.html, replacing the existing page with that name. 

3. Change the Page Heading text to Links and change the Document Title to Francie's Flower Pots 

Website - Links. 

4. Delete the text in the Main page content area. 

5. Type the placeholder text Gardening Links and press [Enter] to create a new line after the text. 

6. In the Properties panel, Format the Gardening Links line as a level 2 heading. 

 

7. Click in the blank line below the heading. 

8. Type Learn to Pot and press [Enter]. 

9. Right click inside the line you just typed and select, List and Definition List. 

From the element indicators at the bottom of the editing area you can see that this line is now a 

Definition Term inside a Definition List. . 

10. Click on the end of this line and press [Enter] to create a new line in the list. This second line will 

be a Definition Data line.  

11. On this definition data line type http://www.pots.com/ and press [Enter]. 

12. Complete the list so that it appears as follows. 
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13. Change each of the web addresses in to links that point to the address.  

If you press Enter to create a new line and no longer want it to be a part of the list, you can press 

Enter a second time to make it a normal paragraph. 

The HTML code for the section you have created should look like the example below. 

 

Note Your definition list doesn’t have to alternate between definition terms and definition data. If 

you view the HTML for the list you have created, you will see that each of the Definition 

Term lines begins and ends with a DT tag while the others have a DD tag. You can easily edit 

the HTML to have several lines of the same type if you need to. 

 

14. At the start of the first line, add the image icon_links.png 2 and set it to right alignment on the 

page. 

15. Save the changes to the document. It should look like the example below. 

 

  

 
2 Image credit - 6716592 © Oleg Pidodnya | Dreamstime.com 
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Exercise 3. Creating a List Using a Table 

Sometimes the best way to create the kind of listing you want is by having the items listed in a table. 

We’ll use a table to create a listing of pots on the products page. 

1. Create a new page based on the same template we used in the last exercise. 

2. Save the new page as gallery.html, replacing the existing page with that name. 

3. Change the Page Heading text to Gallery and change the Document Title to Francie's Flower Pots 

Website - Gallery. 

4. Delete the placeholder text in the Main page content area. 

5. Type the following text and press [Enter] at the end of the line. 

A selection of our products can be seen below. Remember that we have many more types of 

pots available. For a full listing of our pots, or to request a custom made pot, see our Contact 

Us page. 

6) Create a hyperlink so that the words Contact Us link to the file contact.html. 

7) On a new line after the text, insert a table that is 8 rows high, 3 columns wide and 100% width. 

You can press [Ctrl] [Alt] [T] or select Table from the Insert menu. 

8) Choose the Header Top option as you are creating the table. 

6. Leave the other options blank and click OK to create the table. 

 

 

Check the end of this document for a brief description of HTML code for tables. 
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7. Once the table has been created, click in one of the top cells. In the properties panel along the 

bottom, the Header option will appear ticked for any cells in the top row but will be blank in the 

other cells.  

An HTML header cell is usually displayed as bold and centre aligned in a web browser. 

8. In the first row of the first cell enter Name. In the second cell enter Description. Leave the third 

cell blank. 

 

9. Complete the next row as follows. The image to use is the file pot1.gif with the Alt text Red 

Earth. 

 

10. Complete the rest of the table as shown below. Each of the images should be in order so that 

the image for the next row will be pot2.gif then pot3.gif etc. For each image, the alternate text 

should be the name of the pot. There should be seven pots listed when you are done. 

Name Description   

Red Earth 

This ceramic pot is hand crafted from the finest materials so 

that each one is unique. The pots are coated to increase 

durability. 

 

Night Sky 
This glazed ceramic pot is available in lighter and darker 

shades. These are especially well suited to formal gardens. 

 

Country Planter 

The more traditional look of this pot with its glaze design 

and decorative pattern will make it ideal for an informal 

outdoor setting. 
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Chinese Clay 

Flower Pot 

This imported pot stands a little over 40cm in height. The 

sealed finish makes it suitable for outdoor use. 

 

Italian 

Terracotta 

A very traditional looking 20cm high pot, with a narrow 

design making it perfect for long stemmed flowers. 

 

Carved 

Teracotta 

The carved design on this small pot can add some class to an 

entrance area or office setting. 

 

Classic Clay 
A classic design available with a glazed finish to make it 

suitable for the ourdoor patio. 

 

 When you created the table, the table width was set to 100%. In the case of this particular table 

that won’t really matter since the contents of the table probably need that much room anyway but 

widths can be easily cleared.  

11. Move your mouse over the top of the table where the table width appears. Click on the button 

that appears when your mouse is over the width. 

 

12.  From the list that appears select Clear All Widths. You 

won’t see much change since the contents of the table 

will make it stretch to take up the available space but 

there may be some situations where you won’t want a 

specified width and would rather a table that is just 

wide enough to fit its contents 

13. Save the changes and close the document. 

Note You can easily change the width of table columns 

by moving your mouse over the border between 

the columns (or rows) and then dragging them.   
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Online Forms  
Forms are used for a variety of purposes in websites. A form could simply send submitted details to 

an email address, it could be a form which sends the submitted information to retrieve results from 

a database (such as a search engine) or it can be a part of something more complex such as an online 

shopping system. Some may include calculations to add up prices for an order and may include links 

to banking facilities to accept credit card details for orders. Creating a form requires a form handler 

to determine what happens when the website user clicks on the submit button. In many cases, form 

handlers need to be created using a language such as JavaScript, PHP or ASP which are beyond the 

scope of these exercises (though Dreamweaver does provide some help for these and other 

languages and can even do a lot of it for you). 

The part of the form done by HTML is the part that we will be creating in Dreamweaver. This 

includes all the components (elements) in the form such as text areas, radio buttons and combo 

boxes. Our form will be a simple form that takes some details from the user and then sends them 

directly to an email address without the need for a complex form handler, though a good form 

handling script will usually provide neater results. 

Tip Remember to check the code view every now and then or work in split view. Seeing the 

HTML that has just been created as you work in Dreamweaver will make it easy to learn 

more about what is going on in the HTML. Perhaps more importantly, if you have a better 

idea of what’s going on behind the design screen, it makes it a lot easier to fix problems 

when things aren’t looking the way they’re supposed to. As you become more comfortable 

with HTML, you may even find that you prefer working in code view. 
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Exercise 4. Creating the Form 

1. Create a new page based on the same template we used in the last exercise. 

2. Save the new page as ordering.html, replacing the existing page with that name. 

3. Change the Page Heading text to Ordering and change the Document Title to Francie's Flower 

Pots Website - Ordering. 

4. Delete the placeholder text in the Main page content area. 

5. Enter the following text. 

To place an order for any of our products or to request our latest catalogue, complete the 

form below. 

6. Press [Enter] to create a new blank line. 

7. From the Insert menu select Form and then Form. 

 

A dotted red line will appear around the form area. It is important that any objects that are to be 

used by your form are within this area, otherwise they will be ignored by the form. In your HTML you 

will see a <form> and </form> tag marking the start and end of the form area. 

8. Make sure your cursor is within the red form area. We will change some of the form properties 

down in the Properties panel. 

9. Enter orders for the Form ID. In our current website the form name isn’t crucial, but when you 

are creating a form to be used along with scripting and databases it can become important to 

name your form. Especially if there is more than one form in a page. 

10. For Action enter the word mailto: followed by your own email address. This will mean that when 

the form is completed, the results will be sent to you. 

11. Make sure Method is set to Post so that the form will send results. Some types of forms which 

need to retrieve instead of sending information, (such as a form on a search page) will use the 

Get method instead. 

 

Text Controls 
1. Press [Enter] to create a new blank line within the form area. On the second form line we will 

place the buttons that will appear at the end of the form. 

2. From the Insert menu select Form and then Submit Button. 

 

3. Select the button so that its properties are visible in the Properties panel. Change the Value 

property to Submit Order. This will change the text on the button itself. 
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4. Check that the button Name is submit. 

 

5. Click to the right of the button you have created. From the Insert menu select Form and Reset 

Button. 

6. Change the Properties to match the following example. 

 

7. Click the CSS tab on the Properties panel. We will centre the paragraph these buttons are on. 

 

8. Make sure the P element is selected since we want the inline style to apply to the paragraph. 

 

9. Make sure Targeted Rule is <New Inline Style>. 

 

10. Click the center align icon. 

 

Next, we will create the objects that will make up the form itself. First, we’ll create a table that we 

will use to arrange everything on the form. 

11. Click in the first line within the form (the area within the dashed red outline). It should be a 

blank line before the buttons. 

12. Insert a table that has 10 rows, 2 columns, no border, no specified width and 2 cell padding. 

There should also be no headers selected. 

 

http://www.oneil.com.au/pc/


Adobe Dreamweaver 2021  5 – More Page Editing 

© Steve O’Neil 2022 Page 13 of 19 http://www.oneil.com.au/pc/ 

The table cells will look narrow until we’ve added some content in them. 

13. Click in the first cell of the table and type Name: (including the colon: ). 

14. Click in the second cell of the first row (or press the [Tab] key to move to it). 

15. From the Insert menu select Form and then Text. 

16. Dreamweaver may add a text label to the left of the text box. Delete it if it does. 

17. Click on the text field you just inserted so you can change the properties. 

18. The properties along with an explanation of each are listed below. Make the changes indicated. 

Property Purpose Change to: 

Name The name of the control. Name 

Value Specifies text that will already be entered in to the box when the 
web page loads. 

Leave blank 

Size Specifies a width for the box. Width is measured in characters and 
can vary from one browser to another 

40 

Max 
Length 

Places a limit on the number of characters that can be typed in a box Leave blank 

 

 

19. Select the label in the first cell. 

 

20. From the Insert menu select Form and then Label. 

21. In the Properties, we will specify that this label will be associated with the Name text box. 

 

The HTML for the textbox and the label to the left of it should appear as follows. 

 

Having the text next to a form control designated as a label for that control can be useful for screen 

readers which will read out the label when the user focuses on that control. Labels can also assist 

users with clicking on small form elements (such as check boxes) that might be difficult to click on. 

22. Click in the first cell of the second row and type Email Address:. 

23. From the Insert menu select Form and then Email. Delete any text that is added next to the box. 

We could use a regular text box for this control but using the more specific Email type of input 

control can assist web browsers with auto complete features when a user is filling in a form. 

24. Change the Name property of this box to Email and the Size property to 40. 

25. Change the Place Holder property to email@address.com. This property provides this form 

control with faint place holder text indicating to the user how it should be filled in. 
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26. Change the text to the left of the email input control so that it is an associated label. 

27. In the third row, enter the text Phone Number: in the first cell. 

28. In the second cell From the Insert menu select Form and then Tel. 

29. Change the Name property of this box to Phone and the Size property to 40. 

30. Repeat: For the rest of the form, each time you add a new input form control, change the text to 

the left of the new control so that it is an associated label. 

31. On the fourth row, enter the text Pot Name: in the first cell. In the second cell add a textbox the 

same as the name one with the Name property set to Pot_name (with the underscore instead of 

a blank space). 

32. On the fifth row enter the text Quantity: in the first cell. In the second cell add a textbox with the 

Name property set to Quantity and Size as 10. 

Remember to delete any added text next to the boxes and make sure the text in the first column is a 

label associated with the control next to it. So far, the form should be looking like the one below. 

 

Combo Box Controls 
Time to try out some of the other types of form objects, starting with a combo box. 

1. In the first cell of the sixth row type Location:. 

2. In the next cell select Insert, then select Form and Select. Change the Name property to 

Location. 

3. In the Properties panel, click on the List Values button. 
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Here we can create the choices that will appear in the drop-down list. The Item Label will specify the 

text that will appear for each choice in the list. The Value specifies what will be submitted with the 

form when each option is selected. If no value is specified, then the value will be the same as the 

Item Label. 

4. Click in the Item Label section and enter ACT, and in the Value section enter Australian Capital 

Territory. 

5. Click the + button to add another item. Add additional items as shown below. You can use the 

 buttons to change the order of items in the list if you need to. 

ACT Australian Capital Territory 

NSW New South Wales 

NT Northern Territory 

QLD Queensland 

SA South Australia 

TAS Tasmania 

VIC Victoria 

WA Western Australia 

---------------------  

USA  

CANADA  

UK  

NEW ZEALAND  

 

6. Click OK when they have all been entered. 

Note If you choose, you can specify an option to be selected by 

default by clicking on it in the Selected property.  

Text Area Controls 
1. In the first cell of the seventh row, type Address:. 

2. In the second cell of the same row, choose Insert, Form and then Textarea. 

3. Set the properties for the text area as shown below. 
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Radio Buttons 
1. The next row will use radio buttons. In the first cell of the next row type Gardening Skill:. 

2. Select the next cell and then from the Insert menu, select Form and Radio Button. 

3. Change the text next to the radio button to Amateur.  

4. Make sure the radio button you just inserted is selected so you can change the properties. 

5. The properties along with an explanation of each are listed below. Make the changes indicated. 

Property Purpose Change to: 
Name The name of the control – normally radio buttons are in groups 

where only one can be selected at a time. If you want several of 
them to be a part of a group, make sure they all have the same value 
in this property. 

Skill 

Checked If several radio buttons are part of a group, you can set a certain 
radio button to be selected by default. Make sure no more than one 
in a group as set to Checked. 

Unchecked 

Value This specifies what information is sent with the form results if this 
option is selected. 

amateur 

 

 

6. Add two more radio buttons and text so that it looks like the example below. Each one should 

have a Value property similar to the text next to it. If you like you can set one of them to be 

checked by default. They all need to have the same Radio Button Name property (Skill) to tell 

the web browser that they are part of the same radio button group. 

7. Make sure that the text next to each radio button is an associated label. 

 

 

Check Boxes 
1. For the next row, we’ll merge both cells so that they become one cell. Select both cells in the 

row. 

 

2. In the Properties panel, click on the Merge cells icon . This will cause the first cell to have the 

colspan="2" attribute added to its table data (td) tag while the second cell, which is no longer 

needed, will be removed. 

3. Check the Code view [Ctrl] [~] to see the changes. 
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4. In the merged cell, enter the text – Would you like to – followed by a blank space. 

5. From the Insert menu select Form and Checkbox. 

6. Complete the Properties as follows. 

 

7. Add some more text and another Checkbox so that it appears like the following example. Make 

sure the second checkbox has catalogue for the Name and Value properties. 

 

8. For the last row, put the text Comments: in the first cell and another text area called Comments 

in the second cell. Make it the same size as the previous text area (You can copy the previous 

text area and simply change the Name property). 

 

9. Preview the page in your browser to see how the form looks. Try filling in the form and testing 

both the reset and submit buttons. 

10. Try the links in the navigation or footer section to see how the other pages look. 
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Note Since our form action is an email address it will open your email program to send an email 

which is not the best solution and may not work in some email programs. If you search the 

web, you will be able to find a wide range of form mailto scripts, which can be customised to 

suit your needs without too much trouble. If you are going through these exercises in a class, 

ask your teacher if there is one available for your use. 
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Tables HTML 
Tables in HTML are created using several tags. 

First there is the <table></table> tags that define where the table begins and ends. 

The table itself is then structured with each row in the table defined with table row <tr></tr> tags. 

Each cell with a row is then defined with table data <td></td>. 

If some cells in the table need to be designated as headings then they can use table heading 

<th></th> tags instead of td. 

Other tags can provide additional control over table structure and CSS can be used to precisely 

control the appearance of tables. 

The following example shows an example of a simple table and the code used to create the table. 
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