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Adobe Drewamweaver 2021 

4 – Creating A Template 
 

Now that the main page of our website is complete, we need to create the rest of the pages. Each of 

them will have a layout that follows the plan shown below. Creating a rough diagram like this can be 

a useful way of planning a website. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When we are creating several pages that will all be similar, we can use a template to create the basic 

structure and then use that template for a starting point as we create each individual page. The 

template will contain the parts that will be the same on each page (such as navigation and layout) 

while leaving spaces for the parts that will be different on each page.  

Tip An alternative to creating a template is to create one page with the right layout, then use 

Save as from the File menu to make copies of the page under different filenames and modify 

the content of each one. 

  

Main content area 

Page Heading Logo 

Home About Us Gallery Ordering Contact Us Links 

Footer 
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Exercise 1. Starting the Template 

In these exercises we will be continuing the Francie’s Flowerpot website created in the last section. 

1. From the File menu select New or press [Ctrl] [N]. 

 

2. From the list of options, make sure New Document is selected in the left. Select HTML template 

from the Document Types list in the middle and then click Create. 

A new page will be created. We will use this page as the basis for our template. The first thing we 

will do is save the template. 

3. From the File menu select Save or press [Ctrl] [S]. 

 

4. A message may appear telling us we don’t have any editable regions yet. That’s fine since we’ll 

be doing that later. If you like, you can tick the Don’t warn me again option before clicking OK. 

http://www.oneil.com.au/pc/


Adobe Dreamweaver 2021  4 – Creating A Template 

© Steve O’Neil 2022 Page 3 of 11 http://www.oneil.com.au/pc/ 

 

5. In the Save as area, enter Main Pages and click Save. 

Note The template will be saved in a sub folder under the folder your site is in, so you can easily 

open the template for later modifications. 

 

Page Sections 
HTML includes several elements that can be used to denote specific sections of a document. These 

include elements such as Header, Navigation, Main, Article and Footer. Each of these is a block 

element similar to a paragraph. Of course you could simply use paragraphs but using these more 

specific elements can assist with web page accessibility and also assist with web searches as they 

clearly structure your page in a logical way. They can also be used with CSS. E.g. you can create some 

CSS formatting rules that specifically apply to the footer or header section of each page. 

We will use these page section elements to structure our template and all the pages that we will 

create based on our template. We won’t worry about formatting for now. We will start by creating 

the structure of our page with HTML and then later we will use CSS to specify how the site pages 

should appear. 
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Exercise 2. Creating Page Sections 

Now that we have a blank template, we will add the main sections of our page to it. 

1. From the Insert menu, select Header. 

ID can be used to name certain sections of a document. The sections can then be referred to by 

name in CSS and programming scripts. We will later use CSS to format our header section. It won’t 

be necessary to assign it an ID name though since we will only have one header section on each 

page.  

 

2. Click OK to add the header section. 

Some placeholder text will be included which we can replace later with our own content. Now to 

add the other sections. 

3. From the Insert menu, select Navigation. 

Since we already have the header section on the page, we need to specify where Dreamweaver 

should place this new section. 

4. Set the Insert option so that it will be placed before the end of the body section. This will ensure 

that it is placed after the header. Click OK to add the navigation section. 

 

5. Add a Main section after the navigation, followed by a Footer section. 
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If you check the HTML view you will now see elements created for each of those sections. 

 

 

Exercise 3. Adding Template Content 

In our heading section we will add an image followed by some text. 

1. Delete the placeholder text from the Header section. 

2. From the Files panel, locate the image called main_heading_logo.png (it will be in the images 

sub folder). Drag it in to the header section on the page.1 

3. With the image still selected enter Francie's Flowerpots Logo Image for the ALT text. 

 

4. Next to the image type Francie's, followed by a dash. 

 

For the bit after the dash, we will add an editable area so that each page can have different text in 

the header area. 

5. Click after the dash and then from the Insert menu select Template and then Editable Region. 

6. Enter Page Heading for the name of the editable region and click OK. 

 

7. Save changes to the template [Ctrl] [S]. 

 
1 Image credit - 4816765 © Nejron | Dreamstime.com 
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8. Delete the placeholder text in the Navigation section. 

9. Type the names of each of the pages in the site, starting each one on a new line as shown below. 

It won’t look pretty at the moment but remember, we’re simply creating the structure of the site 

for now. Later on, we’ll use CSS to make it look the way we want. 

 

10. Select the lines you have just typed. We will turn them in to a bulleted list. 

11. While they are selected, click the bulleted list icon  in the Properties panel. 

 

 

→ 

 

This will turn the selected paragraphs in to a bulleted list (more on lists later) 

12. Delete the placeholder text in the Main section. 

13. Insert a new Editable region called Main page content. 
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14. Delete the placeholder text in the Footer section. 

15. Press [Enter] to leave a blank line. 

16. From the Insert menu select HTML, then Character and Copyright. This will add a copyright 

symbol to your page. 

17. After the © symbol type 2022 Francie's Flower Pots. The HTML code for the line will appear as 

the following. 

 

18. Copy [Ctrl] [C] your bulleted list from the navigation section and paste it [Ctrl] [V] in the blank 

line of the footer section. 

 

HTML Symbols 
When you add the © symbol, Dreamweaver adds a special code ( &copy; ) similar to the one used 

earlier for non-breaking spaces. The codes for these symbols all begin with & and end with ;. 

There are many HTML Symbols that can be added to a page and some of them can be added through 

Dreamweaver’s Insert menu (for the rest you might need to look up a list of codes). Some of them 

are necessary for characters that are used as part of HTML tags. For example, the symbols < > “ are 

all used as part of HTML. If you wanted any of them to actually appear on your page, you would 

need to use special HTML code instead. 

Some symbols can be used for characters that can’t be typed on your keyboard. These include 

symbols such as ©, ™ and ® as well as accented characters such as â and é. 

A listing of those symbols can be found on the W3C site at https://dev.w3.org/html5/html-

author/charref and some of the more common ones are listed below. 

Symbol Example HTML Code 
Less than < &lt; 
Greater than > &gt; 
Quotation mark “ &quot; 
Ampersand & &amp; 
Copyright © &copy; 
Trademark ™ &trade; 
Pound £ &pound; 
Euro sign € &euro; 
Smiley        &#129409; 
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Exercise 4. Using the Template 

We have already created blank documents for the other pages to test our links, but we won’t keep 

them blank. We’ll create new pages using the template and then save the new pages over the top of 

the old ones. 

1. From the File menu select New [Ctrl] [N]. 

2. When the new file dialog appears, select the Site Templates option on the side. 

 

3. Any Dreamweaver sites you have created will be listed in the middle section. Make sure your 

Francie’s Fabulous Flowerpots site is selected and the Main Pages template is selected. 

4. Click Create to make a new page based on the template. 

5. Move your mouse outside the editable areas and a cross will appear on your mouse. 

 

6. Click in the editable area for the Header. Delete the text that is there and type About Us. 

7. Click in the Main editable area. Replace that text with the following. 

Francie's Flowerpots is a business located in Western Australia. All of our pots are handmade using 

quality materials and techniques. We deliver to anywhere in the world. A sample of our range of 

pots can be viewed from the Gallery page. Other types of pots or custom made pots are available on 

request. Visit our Contact page to request a complete catalogue or more information about what's in 

the gallery. (Press Enter to start a new paragraph here) 
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Francie began making her own pots in the early 90s and began selling them to interested friends as a 

hobby. Since then the business has grown and we now have a team of skilled potters working to 

please our customers. We're certain that we have just the right pot for you. 

8. In the Properties panel, change the Document Title to Francie's Flower Pots Website - About Us. 

 

9. Save the page as about.html. When you are prompted to replace the existing file, click Yes. 

 

10. Click at the beginning of the first line (before the text Francie's Flowerpots is a business) and 

insert the image about_francie.jpg. 2 

11. For the alternate text type About Francie. 

12. Right-click on the image and then select Align and Right so that it will be aligned to the right of 

the page. 

 

13. Save and preview the document. 

 
2 Image credit - 6209426 © Alexander Fedorov | Dreamstime.com 
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Note In the top right corner of the Dreamweaver editing window, you might see a small tip 

indicating that this page is based on a template. 

 

 

Exercise 5. Updating the Template 

When we make changes to a template, it will also change any pages based on that template. 

1. Close the about.html file by clicking on the Close button next to the filename or by pressing 

[Ctrl] [W]. 

 

If you don’t still have the template open, open it. Remember that the template is saved in a folder 

underneath your other files. If you have it showing in your file list you can double click it to open it. 

You can also use the recent files list under the File menu. 

 

2. Select the Home text in the Footer section. 

 

3. Link that text to the index.html file (remember you can use the Point to File icon). 
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4. Create links for each of the other pages. 

 

5. Create links in the Navigation section (or simply copy the list you have just edited in the Footer 

section). 

6. Press [Ctrl] [S] to save the changes to the template. You will now be asked if you would like to 

update pages that are based on the template. 

 

7. Click Update to update dependent pages. Another message will appear once the update is done. 

You can close that message. 

8. Open the about.html page. You will see that the changes to the template have been applied to 

this page. 

9. Preview the page in your web browser. 

 

Tip Since we created a site in Dreamweaver, all of the files in the site folder are monitored by 

Dreamweaver. If you renamed one of those files in the Files panel, Dreamweaver would 

offer to update any links that point to that file. Note that this would not happen if you 

renamed or moved a file outside of Dreamweaver. 
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